Introdução à Computação com Software Livre

Fonte: Wikiversidade

Introdução à Computação com Software Livre ambientação e tarefas básicas com Linux.

Slides[editar | editar código-fonte]

Aula1: https://cryptpad.fr/file/#/2/file/QNLQ8KBnLvI4yFrtKEzwtgx1/

Aula2: https://cryptpad.fr/file/#/2/file/rU0b7DUChKhphaSf8O+0tCCb/

Aula3: https://cryptpad.fr/file/#/2/file/0c82+hNb4qvvfiuYy4ZN1ld8/

Objetivo[editar | editar código-fonte]

O aluno deve entender o funcionamento básico de um computador, tendo noções sobre seus componentes e periféricos. Depois, compreender as unidades de medidas para CPU, memória, disco e arquivos, ao mesmo tempo que se familiariza com os programas mais usados, como editores de textos, planilha, apresentação de slides e navegador de Internet. Mais na frente, o aluno deve entender melhor o funcionamento do sistema operacional GNU/Linux e os comandos básicos em seu terminal. Ao final, compreender o que é Software Livre, suas questões éticas e filosóficas, as licenças de software livre e os padrões abertos (em particular, o ODF).

Notas de aulas[editar | editar código-fonte]

O que é um computador?[editar | editar código-fonte]

O computador é uma máquina eletrônica composta por Hardware e Software que possibilitam o processamento de dados, através de cálculos, para abstrair funções e possibilitar realiza-las de forma simplificada ou até de maneira automática.

Hardware[editar | editar código-fonte]

O Hardware corresponde às partes físicas do sistemas que suporta o processamento da informação, que são feitas por componentes eletrônicos como circuitos de fios, periféricos e toda parte física que é necessária para que o sistema funcione corretamente.

Dentre as principais peças de Hardware do computador temos às:

  • Processador (CPU): Responsável pelos cálculos e processamento de dados.
  • Memória de acesso aleatório (RAM): Memória de curto prazo do computador, usada para armazenar dados temporariamente de maneira rápida.
  • Disco Rígido(HD): Guarda todos os dados do usuário, podendo ser dados pessoais ou programas.
  • Placa Mãe: Organiza as demais peças e permite que elas se comuniquem entre si, sendo ela a base para que todas as peças funcionem de maneira harmônica.
Como funciona um computador e seus componentes[editar | editar código-fonte]

Primeiramente, ao ligarmos o computador na tomada, a fonte que é um componente do computador responsável por regular a tensão e a potência que irá para os demais componentes, fornece energia aos demais componentes e, assim, ele fica pronto para ligar ou em ficar em "stand by". Ao ligarmos, o computador inicia um programa básico chamado BIOS (Sistema Básico de Entrada/Saída), que é um programa de testes que irá verificar se os componentes do computador estão funcionando corretamente. Em seguida, o computador normalmente irá começar ler o dados do Disco Rígido. Para carregar os programas e executar as funções esperadas, o programa é "movido" para a memória RAM e com isso os dados são enviados para processamento na CPU pelo barramentos de dados da Placa Mãe. Assim, a CPU pode interpretar os dados, executar os comandos designados a ele e enviar os dados para as unidades de memória ou para algum periférico de saída.

A arquitetura do computador interligando periféricos, os componentes do computador e a CPU
Recomendação ao instrutor(a): deve tentar abrir um computador e mostrar os seus componentes aos alunos, ou levar para a sala de aula alguns dos componentes, separadamente.
Principais periféricos[editar | editar código-fonte]

Os periféricos são dispositivos conectadas e instaladas no computador para ser o intermediário entre homem e máquina. Utilizadas para que se faça entrada de dados para que o computador possa processá-las e retornar uma "saída" desejada. Por exemplo, você pode querer que o computador reproduza determinada música, e, para isso, você pode utilizar o Teclado ou o Mouse.

Periférico de entrada[editar | editar código-fonte]
  • Teclado: Dispositivo que contém diversões botões representando as letras e número utilizadas no nosso alfabeto seguindo determinada estrutura e arranjo de teclas para melhor ergonomia e facilidade de digitação.
  • Mouse: Dispositivo utilizado em conjunto com programas que possuem interface gráfica para, por exemplo, apontar para determinados botões ou selecionar objetos dentro do computador, auxiliando na entrada de dados. Ao utilizar o teclado para abrir um programa, é necessária uma série de comando, enquanto que, com o mouse, você consegue abrir o programa com um click.
  • Digitalizador: Dispositivo utilizado para digitalizar imagens, fotos e documentos, para que se possa compartilhar, armazenar ou editar. A palavra "digitalizar" significa: criar um arquivo digital que represente um determinado objeto físico.
Periférico de saída[editar | editar código-fonte]
  • Monitor: Dispositivo com a função de transmitir informações através de imagens ao usuário, para que seja possível visualizar a interface gráfica do software e visualização dos dados.
  • Caixa de som: Dispositivo com alto-falantes controlados pelo computador para transmitir informações através do som.
  • Impressora: Dispositivo utilizado para impressão de foto, gráficos, textos.
Recomendação ao instrutor(a): deve demonstrar o funcionamento do teclado, já utilizar um editor de texto (recomenda-se o GEdit, neste momento) e um navegador (preferencialmente, o Firefox, por ser livre).
Recomenda-se salvar um arquivo produzido no GEDIT e, com este exemplo, apresentar o conceito de pasta/diretório (abrindo o Gerenciador de Arquivos e, depois, mostrar as propriedades do arquivo (opção que aparece ao clicar com o botão direito).
Software[editar | editar código-fonte]

Software é uma solução abstrata dos problemas computacionais. O software, em um sistema computacional, é o componente que contém o conhecimento relacionado aos problemas a que o programa em questão se aplica. O Sistema Operacional (SO), que é um conjunto de programas que funciona para administrar e gerenciar os recursos de um computador, fazendo a comunicação com o hardware e garantindo que tenha memória para que os programas funcionem corretamente, acessando sistemas de arquivos, controlando os periféricos conectados ao computador. Além disso, um SO faz a ligação entre o computador e o usuário, de maneira a proporcionar uma utilização de todos os recursos.

Unidades de Medidas[editar | editar código-fonte]

Dentre as unidades de medidas na computação, uma das mais importantes que nos ajudará a entender como um computador realiza suas funções é o Bit, que representa os dígitos binários que podem ser 0 ou 1, a menor unidade de informação, e que são essenciais, pois é a forma como a CPU entende os dados. Porém, com apenas duas possibilidades, só conseguimos representar duas coisas, ou seja, de maneira binária, os valores Verdadeiro e Falso.

Para conseguirmos representar diversos valores numéricos e também qualquer outro tipo de dados mais complexo, é feito uma combinação de bits para que se possa representar mais coisas de maneira semelhante a um dicionário, em que cada coleção de 0 e 1, diferente uma da outra, represente um comando especifico para o computador.

Um conjunto de 8 bits é 1 Byte, que, seguindo uma análise combinatória, em que cada dígito do Byte pode ser 1 ou 0, e multiplicando esses números de possibilidades a cada casa decimal, que seria equivalente a 2*2*2*2*2*2*2*2 = 2^(8) e que resulta em 256 valores diferentes (por exemplo, 10110111). Com essa quantidade de possibilidades, podemos transmitir várias informações em diferentes proporções. Na tabela a seguir, vemos as unidades de medidas mais comuns de serem vistas em seu computador.

Observação: Os prefixos utilizados na tabela são referente a base 10, sendo Kilo = 10^3, Mega = 10^6 , Giga = 10^9, e assim por diante.

Tamanho quantidade Nome Abreviação
8 bits 1 Byte
1024 bytes 1 Kilobyte Kb
1024 kilobytes 1 Megabyte MB
1024 megabytes 1 Gigabyte GB
1024 gigabytes 1 Terabyte TB
Números binários[editar | editar código-fonte]

Agora que sabemos mais sobre as unidades de medidas de informação no computador, podemos entender melhor como os dados são interpretados e transformados em coisas para o entendimento do usuário. Considerando o bit a menor unidade de informação, e ela podendo ter apenas dois valores, então, temos um sistema de base 2 para representar os diversos valores. Com o agrupamento em bytes, podemos representar mais informações e para cada tipo de informação utilizamos determinados dicionários, por exemplos, podemos transformar o números binários em decimais.

Para conseguirmos processar a informação em binário e interpretá-la em decimal, devemos seguir uma lógica em que será principalmente considerada a sua ordem e o valor verdadeiro/falso que o bit pode significar. Cada dígito do número binário que se deseja transformar em decimal irá afirmar a existência ou não existência de uma potência de 2, e iremos organizar as potências da direita para a esquerda de forma crescente, partindo do expoente zero até 7 que serão os 8 bits de 1 byte.

Exemplo: Vamos realizar todos os passos para transformar o número binário 10110111 em decimal. Seguindo o esquema da Tabela 2, temos os dígitos binários e as potência de 2 organizada de maneira correta, sendo assim, iremos obter o resultado em decimal, somando todas as potências de 2 existentes representada pelo bit 1. Logo, 2^7 + 2^5 + 2^4 + 2^2 + 2^1 + 2^0 = 183.

Tabela 2
Número binário 1 0 1 1 0 1 1 1
Potências de 2 7 6 5 4 3 2 1 0

Observação: Por conta das respectivas posições dos bits em comparação com as potências de 2, é notável que os dígitos mais a esquerda irão ter maior peso no cálculo, logo ele é chamado de dígito mais significativo. Por outro lado, o dígito mais a direita, por possuírem potências menores de dois, ele é chamado de dígito menos significativo.

Diferença entre armazenamento local e em nuvem[editar | editar código-fonte]

[TODO-Mirelle: Fazer/completar]

Recomendação ao instrutor(a): ao demonstrar o teclado, salvar o arquivo do documento usado de exemplo e explicar as unidades de medidas a partir do primeiro arquivo salvo.
Fazer uma simulação de compra de um computador em um site de forma que possamos explicar e demonstrar as medidas de CPU, memória RAM e HD.

Pacote LibreOffice[editar | editar código-fonte]

O Pacote LibreOffice inclui em si vários sistemas de software comumente usado em trabalhos de escritório como editor de texto (Writer), editor de planilhas(Calc), editor de slides (Impress), entre outros. Abaixo, vamos ver cada um desses programas mencionados e aprender a usá-los.

Editor de texto (Writer)[editar | editar código-fonte]

O Writer é um software de processamento de texto, com diversas funções para formatar, editar, verificar e corrigir ortografia e muito mais.

Na figura abaixo, vemos a Área de trabalho do Writer que tem diversas barras de ferramentas para facilitar a escrita e edição para o usuário:

  • Barra de Título enuncia o nome do programa e o nome do arquivo de texto que estamos utilizando.
  • Barra de Menus possui diversos acessos às funções que o software realiza.
  • Barra de Ferramentas agrupa as funções mais utilizadas nos Menus, facilitando o acesso a essas opções.
  • Barra de Formatação agrupa as funções mais utilizadas do Menu 'Formatar', facilitando o acesso às opções de formatação de texto.
  • Régua utilizada para definir o espaço em que a entrada de texto pode ocupar da folha.
  • Entrada de Texto é a área onde iremos digitar e escrever e realizar as edições.
  • Barra Lateral agrupa funções de formatação e propriedades da página e de texto, e muito mais.
  • Barra de Status exibe ao usuário informações sobre o arquivo, opções de zoom e modos de exibição.
Ambientação do Software e principais ferramentas que iremos utilizar.
Área de trabalho do Writer














Formatação de texto[editar | editar código-fonte]

Para conseguirmos mudar a fonte do texto podemos selecionar na Barra de Formatação em Nome da fonte, e clicando na seta para baixo irá surgir várias opções de fontes de texto, sendo as mais indicadas no, LibreOffice, Liberation (Liberation Sans, Liberation Serif e Liberation Mono), Bitstream (Bitstream Vera Sans, Bitstream Vera Sans Mono e Bitstream Vera Serif) e DejaVu (DejaVu Sans, DejaVu Sans Mono e DejaVu Serif) para realização dos mais diversos trabalhos. Outra forma é você ir até a Barra Lateral e clicando em Propriedades irá surgir uma janela com as propriedades do texto, sendo o Estilo, Caractere e Parágrafo. No espaço de Caractere, também há a opção de você escolher uma fonte para seu texto. Também podemos alterar o tamanho da fonte colocar em Negrito ou em Itálico, sublinhar, mudar a cor da fonte e várias outras formatações. Podemos Alterar o Alinhamento de todo o texto sendo o modo 'Justificado' mais recomendado para trabalhos mais formais. É possível também personalizar Espaçamentos de parágrafos ou entre linhas, e personalizar o recuo do parágrafo.

Podemos configurar as Margens dos nosso parágrafos indo na Barra Lateral > Propriedades no campo Parágrafo podemos adicionar ou retirar o recuo que daremos a nossa margem e personalizar a quantidade do espaçamento que vamos dar a cada recuo.

Podemos também alterar o estilo de texto tanto na Barra de Formatação quanto na Barra Lateral > Propriedades. Que são predefinições de formato de texto, com tamanho, em Negrito ou não, em Itálico ou não, de maneiras diferentes utilizadas usualmente em determinadas funções, essas quais também são enunciadas nas opções de estilo de texto. Por exemplo: Titulo 1, 2, 3 e 4, Citações, Subtítulo.

Marcadores e Numeradores[editar | editar código-fonte]

Podemos adicionar Marcadores e Numeradores que são basicamente listas numeradas ou não ao nosso texto. Podemos inserir facilmente pela Barra de Formatação, indo em Alternar lista não ordenada ou apertando Shift+F12, e também podemos inserir listas numeradas pela Barra Formatação, indo em Alternar lista numerada ou apertando F12. Ao lado dos dois tipos de lista temos várias predefinições prontas para uso.

Para as mais diversas personalizações podemos ir no menu Exibir >Barra de Ferramentas> Marcadores e Numeração. Após isso irá aparecer uma nova barra na área de trabalho do Writer, que terá diversas opções de navegação na lista, opções de inserir listas dentro de listas e na opção "Marcadores e Numeradores" irá abrir uma janela com abas de tipos de lista e nas abas "Posição" e "Personalizar" podemos alterar as configurações e montar listas ou tópicos de diversas formas.

Inserir figuras[editar | editar código-fonte]

Indo na Barra de Menu Inserir vemos que é possível inserir diversas coisas, como uma Quebra de Página, Figuras e Gráficos, Formas Geométricas, Hyperlinks, entre outras.

Umas das opções mais usuais é a inserir Figura ( Inserir > Figura ...), ao clicar na opção será aberta uma janela do "Explorador de Arquivo" do computador possibilitando ao usuário, buscar e selecionar a imagem que ele deseja inserir. Selecionando a imagem automaticamente, ela irá para a área de trabalho do Writer, e clicando na da imagem irá aparecer alguns pequenos quadrados em volta da mesma, clicando, segurando e arrastando nesses quadrados podemos redimensionar a imagem para outros tamanho dentro da pagina.

Tabelas[editar | editar código-fonte]

Ainda na Barra Menu, temos a opção de Menu Tabela. Clicando nela, irá aparecer diversas opções como Inserir tabela, inserir, selecionar, tamanho, entre outras. As opções citadas são as principais ferramentas de manipulação de uma tabela. Inicialmente, para criar uma tabela vá em Tabela>Inserir tabela e irá aparecer uma janela com três áreas: Geral, Opções e Estilo. Em Geral é possível escolher um nome para a tabela e selecionar a quantidade de linhas e colunas da tabela. Em Opções é possível escolher a forma como os dados da tabela vai se comportar em relação a página. Em Estilo é possível escolher entre diversas predefinições de tabelas para ser utilizado e aplicar tal estilo a sua tabela. Após configurar a tabela, e clicar em Inserir, a tabela irá automaticamente para a área de trabalho do Writer. Clicando em cima da tabela, irá surgir uma barra, acima da Barra de Status, que agrupa a maioria das funções do Menu Tabela, opções usadas para personalização da tabela. Dentre essas opções na nova barra, podemos selecionar as Propriedades da Tabela, e, assim, podemos personalizar a tabela de todas as maneira.

O usuário pode inserir os dados na tabela de maneira similar a entrada de texto comum, porém respeitando os espaços delimitados pela tabela.

Salvar, Salvar Como e Gerar PDF[editar | editar código-fonte]

Indo no Menu Arquivo irá aparecer diversas opções, como Salvar o arquivo, Imprimir, Abrir ou Criar um arquivo. Caso o arquivo tenha sido iniciado diretamente pelo pacote LibreOffice, ao clicar na opção Salvar, será aberto uma Janela do "Explorador de Arquivo" para que você selecione um local de dispositivo de armazenamento (geralmente, o HD do computador) para que o arquivo seja salvo. É importante também adicionar um nome, caso o contrário o seu arquivo ficará com o nome 'Sem título' e será facilmente "perdido" ou confundido com outros arquivos. Se o usuário fizer outras alterações no arquivo, e quiser salvá-las, ao ir em Arquivo>Salvar, o arquivo será salvo sem a necessidade de realizar o processo passado. Entretanto, se clicarmos em "Salvar Como...", será aberto uma janela do "Explorador de Arquivo", e, assim, você poderá escolher um outro local para salvar o arquivo ou renomear o mesmo também.

Umas opções é a de Exportar e "Exportar como..". Ao clicar em Exportar, será aberto uma janela do "Explorador de Arquivo" e o usuário poderá selecionar um local para salvá-lo e nomeá-lo de maneira similar ao processo de Salvar, mas ao exportar, abaixo do campo nome, haverá como selecionar o Tipo ou formato diferente de arquivo que o usuário deseja, entre eles o PDF.

O formato PDF (O Formato de Documento Portátil) é um tipo de arquivo para visualização de documentos. Ele se propõe a ser um formato de fácil compartilhamento e visualização dos documentos, sem problemas de perda de informação entre diferentes sistemas operacionais e programas de visualização de PDF. Ao clicar em Arquivo>Exportar como...>, é possível Exportar diretamente como PDF, que será semelhante à opção normal de Exportar, porém com o formato PDF já selecionado. Se clicarmos em Exportar como PDF irá abrir uma janela para que se possa personalizar as configurações de exportação, como a resolução (qualidade de imagem), adicionar assinatura, selecionar determinadas paginas ou todas as paginas, entre outras opções.

Recomendação ao instrutor(a): Tentar propor atividades interdisciplinares com outros professores (português, preferencialmente) da grade curricular da escola. Ou usar como exemplo textos relacionados com os assuntos que estão sendo tratados nas atividades curriculares dos alunos, na respectiva em que estão conhecendo o Writer. Ou ainda, por exemplo, caso o aluno tenha que entregar um trabalho de uma disciplina na semana correspondente a este tópico do nosso curso, ele pode usar esse trabalho da disciplina como alvo durante a aula para exercitar o que está sendo apresentando quanto a formatação de texto etc.
Planilha (Calc)[editar | editar código-fonte]

O Calc é o software de documento de planilha do LibreOffice. Ele pode ser usado para inserir os dados na planilha, manipulá-los e utilizar as mais diversas funções que o programa oferece para se obter resultados.

Elementos básicos de uma planilha eletrônica: Célula, Valores e Fórmulas[editar | editar código-fonte]

Na figura abaixo, vemos a Área de trabalho do Calc, que possuem muitas áreas semelhantes ao Writer e tendo poucas alterações. Temos, também, novas barras de ferramentas para auxiliar e facilitar a manipulação dos dados.

  • Barra de Formatação agrupa as funções mais utilizadas do Menu 'Formatar': facilitar o acesso e auxilia na formatação dos números e das células.
  • Célula é o cruzamento de uma coluna com uma linha, que é endereçada por uma identificação ("nome da célula"), sendo a junção do nome da coluna e da linha (por exemplo, a célula da junção da coluna B com a linha 2 é identificada como "B2"). A célula é utilizada para armazenar dados, como textos, números, fazer referências aos dados de outras células ou cálculos.
  • Caixa de nome da célula fornece o nome/endereço da célula ativada, ou seja, a que está selecionada ou sendo editada no momento.
  • Cabeçalho de Linha ou de Coluna é a coleção de nomes de cada Linha ou Coluna, exposta para auxiliar e possibilitar a seleção de uma Linha ou Coluna inteira.
  • Barra de Formula é uma maneira de inserir dados na célula ativada, possibilitando adicionar funções matemáticas como somatório, média, entre outras, e determinar o resultado em uma célula específica para que também possa ser usada.
Campos na Área de Trabalho do Calc













Funções[editar | editar código-fonte]

Com o Calc podemos realizar cálculos matemáticos como Somar, Subtrair, calcular a Média, o Máximo e o Mínimo dos dados que temos na planilha.

Primeiramente, para conseguirmos utilizarmos as funções é importante termos alguns dados nas células. Podemos selecionar, na barra de fórmula, o Assistente de Funções (ao lado da "caixa de nome da célula"): ao clicar, será aberta uma janela em que é possível buscar e selecionar a função que desejamos utilizar. É importante notar que as funções no Calc possuem nomes diferentes, ou pode ter abreviações, da função matemática real.

Recomendação ao instrutor(a): mostrar exemplos simples das funções Soma, Média, Máximo e Mínimo, comparando, no caso de Soma e Média, quando se faz usado dos operadores aritméticos.


Funções básicas

Indo em Barra de formula>Assistente de Funções, na aba Funções, há uma caixa de opções 'Categorias' e com ela podemos selecionar as funções Matemáticas, Estatísticas ou Recém-utilizadas, que agrupa as funções mais comumente usadas pela comunidade. Após isso, selecione a função desejada. Ao lado, na mesma janela, irá surgir uma opções para que o usuário possa inserir diretamente os números que ele quer utilizar ou buscar as células na planilha para que seja realizado a função. Também, é possível visualizar o resultado conforme é inserido os dados à função, e, clicando no botão "OK", teremos o resultado guardado na célula que escolhemos anteriormente.

É possível realizar as funções de maneira mais ágil pela Barra de Formula>Linha de Entrada, porém é necessário conhecimento dos nomes das funções e da maneira como são inseridos os dados. No caso da soma, podemos escrever na Linha de Entrada "=" que é o sinal de que uma fórmula ou função será realizada e em seguida "FUNÇÃO( )", onde no espaço 'FUNÇÃO' pode ser qualquer função visualizadas no Assistente de Funções, e vamos inserir os números a serem somados por ponto-e-vírgula ";". Dessa forma, "=FUNÇÃO( 1; 2; 3)" , teclando o botão "ENTER", o calculo será realizado e será guardado na célula que escolhemos anteriormente.

E também podemos selecionar várias células, para isso vamos em Barra de Formula>Linha de Entrada e no mesmo comando ' =FUNÇÃO( ) ' , com a entrada selecionada no meio dos parênteses, podemos clicar e arrastar, e concomitantemente irá surgir uma retângulo de traçado rosa ao entorno da células selecionadas, expanda a área do retângulo para as células desejadas e tecle 'ENTER' para que a função será realizada e guardado na célula que escolhemos anteriormente.

Exemplificação e utilização de funções no Calc.

Função SE

A função "SE" é baseada em uma condição que é similar a uma pergunta, podendo ser verdadeiro ou falso o valor dessa condição, e para cada valor terá um resultado diferente. Por exemplo, vamos supor que eu tenha dois dados (números) que representam minhas notas em duas provas; para conseguir se aprovado, é necessário que a média das duas notas seja maior ou igual a 6, ou seja, dependendo das notas, o resultado é "aprovado" ou "reprovado". Dessa forma, a função SE, no Calc, na Linha de Entrada, é estruturada da seguinte forma "=SE( Teste ; Então ; Senão)". Para expressarmos a condição do exemplo anterior, utilizaremos a função MÉDIA, logo a função SE será formada da seguinte maneira:

"=SE( MÉDIA( DADOS ) >= 6 ; APROVADO ; REPROVADO)"

Observação: Para os testes/condições será necessária a utilização de operadores lógicos. Abaixo segue uma tabela com os operadores de maneira simples e composta. Considere que a dois valores X, a esquerda, e Y, a direita do operadores, pois o resultado será relativo a posição de cada valor.

Operadores significado
> X MAIOR QUE Y
< X MENOR QUE Y
= X IGUAL A Y
<= X MENOR IGUAL A Y
>= X MAIOR IGUAL A Y
<> X DIFERENTE DE Y
Recomendação ao instrutor(a): Criar uma tabela contendo as notas de uma turma em uma determina disciplina, fazer a média das notas e dizer se o aluno foi aprovado ou reprovou.
Gráficos[editar | editar código-fonte]

Indo em Barra de Menus > Inserir> Gráficos, ao clicar, irá surgir uma janela com diversas opções sobre o gráfico, sendo o primeiro dele a tipo de gráfico e suas personalizações de estilo, por exemplo: Gráfico de dispersão, Gráfico de linha e Gráfico de barra. A segunda opção são referentes aos intervalos de dados, onde há uma barra de entrada para selecionar o intervalos de dados, podendo ser diferentes colunas para serem diferentes series de dados. Na terceira opção, podemos selecionar e criar séries de dados e selecioná-las na planilha para que façam parte do gráfico. E na quarta parte podemos alterar o nome do gráfico, nomear cada eixo do gráfico e configurar as legendas do gráfico.

Recomendação ao instrutor(a): Fazer um gráfico baseado no exemplo anterior, mostrando alunos aprovados e reprovados.
Exporta e imprimir planilha[editar | editar código-fonte]

Indo em Barra de Menus> Arquivo, ao clicar, irá surgir uma janela com diversas opções. De maneira semelhante ao Writer, podemos Salvar, Exportar e Imprimir.

Para Salvar o arquivo da planilha do Calc, vamos em Barra de Menus> Arquivo> Salvar: irá surgir uma janela do "Explorador de Arquivo" para que se possa nomear o arquivo, escolher o local a ser salvo e o formato a qual deseja ser salvo.

Para exportar a planilha vamos em Barra de Menus> Arquivo>Exportar dessa forma podemos mudar para formatos que a opção Salvar não nos permite. E podemos também Exportar como PDF.

Para Imprimir a planilha vamos em Barra de Menus> Arquivo>Imprimir..., ao clicar irá, abrir uma janela para as configurações da impressão, podendo selecionar a impressora, quais paginas serão impressas, o formato da folha de impressão etc.

Recomendação ao instrutor(a): Tentar propor atividades interdisciplinares com outros professores (matemática ou ciências naturais, preferencialmente) da grade curricular da escola. Ou usar como exemplo organização de dados ou cálculos relacionados com os assuntos que estão sendo tratados nas atividades curriculares dos alunos, na respectiva em que estão conhecendo o Calc. 
Apresentador (Impress)[editar | editar código-fonte]

O Impress é o software de apresentação e edição de slides do pacote LibreOffice que cria apresentações de slides no formato ODP (OpenDocument Presentation), o que facilita a compatibilidade com outros softwares e na exportação para outros formatos de arquivo.

Criar uma Apresentação: em branco, a partir do modelo[editar | editar código-fonte]

Ao abrirmos o Impress, será aberto a área de trabalho e uma janela para que possamos escolher modelos de slides com características e elementos gráficos diferente, como fonte de letra, plano de fundo e formatação.

Para criar um projeto em branco, ou seja, para personalizar os slides do zero, apenas clique no botão 'Fechar' e automaticamente irá para a área de trabalho do Impress com um projeto em branco.

Abrir Apresentação Existente[editar | editar código-fonte]

Para abrir uma apresentação já existente, vá em Barra de menus>Arquivo>Abrir... e irá abrir uma janela do Explorador de Arquivo do seu Sistema operacional, possibilitando navegar pelo seu computador e escolher o arquivo que deseja abrir no Impress.

Área de Trabalho de Apresentação[editar | editar código-fonte]

Na figura abaixo, vemos a Área de trabalho do Impress, que possuem muitas barras de ferramentas semelhantes ao Writer e ao Calc, e tendo poucas alterações. E temos novas barras de ferramentas para auxiliar e facilitar a manipulação dos dados.

  • Barra de Desenho: guarda as principais funções utilizadas para inserir elementos gráficos nos slides e fazer personalizações dos mesmos.
  • Painel de Slides: painel que auxilia na visualização das paginas de slides e agiliza a navegação.
  • Barra Lateral: já presente em outros programas do pacote LibreOffice, porém no Impress agrupa as propriedades dos slides, Estilos, Galeria, Navegador, Animações, Transições e formas.
Área de trabalho do Impress












Trabalhando com slides[editar | editar código-fonte]

Nos Slides podemos inserir textos e imagens, gráficos, entre outros elementos, de maneira organizada a cada página, para montar apresentações que tenham uma boa cadência e para que consiga conduzir os espectadores de uma maneira complementar à fala.

Uma maneira de inserir slides é indo até o Painel de Slides e clicar com o botão direito do mouse e selecionar a opção 'Novo Slide', assim será inserido um slide na sequência do slide que estava selecionado anteriormente. Ainda, de forma mais rápida, podemos aperta as teclas ' Ctrl+M ' que irá surgir uma novo slide.

Podemos remover um slide indo até o Painel de Slides e clicar com o botão direito do mouse e selecionar a opção 'Excluir Slide', dessa forma, irá remover o slide selecionado; ou podemos apertas as teclas ' Ctrl+X ' que o slide será removido.

Podemos também renomear os slides indo até o Painel de Slides, selecionar um slide e clicar com o botão direito do mouse e selecionar a opção 'Renomear slide', ao clicar irá surgir uma janela com uma caixa de entrada de texto para que o usuário possa editar o nome do slide.

Podemos também duplicar os slides indo até o Painel de Slides. Para isso, selecione o slide que deseja duplicar e clique com o botão direito do mouse, selecionando a opção 'Duplicar slide': ao clicar irá surgir uma cópia idêntica do slide que você selecionou.

Podemos também mudar o Layout do Slide, isto é, a disposição ou organização as informações que serão apresentadas. Para isso, vá em Barra Lateral>Propriedades. Nas Propriedades dos Slides, há dois campos: um deles, 'Slides', se refere à formatação do slide; o segundo, 'Leiautes', se refere à organização dos textos e imagens que serão inseridas. Em 'Leiautes', há várias predefinições que o usuário pode escolher, porém também é possível inseri manualmente cada bloco de texto ou imagem, bem como, editar sua organização, formando o seu próprio Layout de slide.

Trabalhando com Formas: Formas Básicas[editar | editar código-fonte]

Para inserir formas geométricas como quadrado, elipse e triângulo, que são as Formas Básicas, podemos ir em Barra de Desenho, onde é visível ao usuário algumas formas geométricas simples, como o retângulo e a elipse, para que ele possa selecionar. Ao clicar em uma das opções, o cursor do mouse será modificado; assim, ao clicar e segurar o botão do mouse em cima do slide em que você deseja inserir a forma, arraste até que a forma esteja do tamanho desejado e solte o botão para confirmar. Dessa forma, você conseguira inserir a forma desejada.

Com a forma já inserida é possível editá-la, clicando uma vez em cima da forma, podemos editar o seu tamanho e suas dimensões como comprimento e largura. Clicando uma segunda vez, podemos alterar o ângulo que a forma está e seu eixo de rotação, diversificando assim a personalização.

Podemos também mudar a cor da forma, indo em Barra de Desenho: temos como editar a 'Cor de preenchimento', clicando uma vez na seta que está apontando para baixo ao lado direito, selecionando a cor que desejamos preencher a nossa forma, e clicando uma outra vez em cima de 'Cor de preenchimento' . Podemos também mudar a cor da linha de contorno da forma, de maneira análoga à 'Cor de preenchimento'

Inserindo Figuras: do Arquivo e da galeria[editar | editar código-fonte]

Podemos inserir figuras indo em Barra de Menus>Inserir> Figuras...: ao clicar, será aberta uma janela do Explorador de Arquivo do seu sistema operacional, assim é possível navegar em seu computador e escolher uma figura a ser inserida no slide. Após selecionar a imagem, clique em 'Abrir' e sua figura será inserida no slide, possibilitando editar o seu tamanho em relação ao slide, para que se possa formar um layout para apresentação.

Podemos também inserir figuras que já estão predefinidas no Impress, como setas, formas, alguns ícones gráficos, que é contemplada na galeria. Para acessarmos, vamos em Barra Lateral>Galeria: ao clicar, será aberta uma aba com duas áreas, uma que se refere a tipos de imagens (por exemplo, Ícones, Setas, Diagramas) e a outra área são as imagens pertencentes a galeria do Impress, para que o usuário possa selecionar a figura de maior interesse.

Barra de Ferramentas[editar | editar código-fonte]

A barra de ferramentas agrupas diversas funções úteis para agilizar o processo de edição de slides, o que nos dá a possibilidade de inserir gráficos, hiperlinks, fontworks (fontes personalizadas), caixa de texto e, entre outras, salvar nosso arquivo para não perder as edições realizadas. Podemos também exportar o arquivo em PDF, assim como fizemos no Writer.

A Barra de ferramentas também possibilita que o slide seja apresentado, tendo duas maneiras de começar a apresentação: a primeira é começando pelo slide inicial, que também podemos realizar tal função teclando 'F5'; ou apresentar pelo slide selecionado, via a função teclando 'Shift+F5'.


Software livre[editar | editar código-fonte]

Software livre é o software que concede liberdade ao usuário para executar, acessar e modificar o código fonte, e redistribuir cópias com ou sem modificações. Sua definição é estabelecida pela Free Software Foundation (FSF) em conjunto com o projeto GNU. Segundo a definição criada por Richard Stallman, fundador da FSF, software livre é qualquer programa de computador que pode ser usado, copiado, estudado, modificado e redistribuído sem nenhuma restrição. É permitido vender software livre, entretanto as mesmas liberdades são válidas para o comprador. O termo Código aberto (Open Source do Inglês), assim como definido pela Open Source Initiative, não abrange as mesmas liberdades que o software livre, que não se refere apenas ao acesso ao código fonte. Assim, todo software livre é código aberto, mas nem todo código aberto é software livre.

É importante destacar que software livre não equivale a software gratuito, já que o "livre" do termo remete a noções mais do que simplesmente monetárias. Essa distinção é importante de ser feita sobretudo para os falantes de inglês, língua em que o termo free software foi cunhado. Há uma frase conhecida de Richard Stallman que exemplifica tal ideia de forma cômica, comentando que é "livre" (free) como em "liberdade de expressão" (free speech), e não como em "cerveja grátis" (free beer).


Definições

As duas principais organizações internacionais responsáveis pela proteção e promoção do software livre, a FSF e a Open Source Initiative (OSI), atuam também para garantir que os termos Free Software e Open Source sejam utilizados de forma correta. A FSF considera um software como livre quando atende quatro tipos de liberdade para os usuários:

  1. A liberdade de executar o programa, para qualquer propósito;
  2. A liberdade de estudar o programa, e adaptá-lo para as suas necessidades.
  3. A liberdade de redistribuir cópias do programa de modo que você possa ajudar ao seu próximo;
  4. A liberdade de modificar (aperfeiçoar) o programa e distribuir estas modificações, de modo que toda a comunidade se beneficie.

Lembrando que o acesso ao código-fonte é um pré-requisito para as liberdades 2 e 4, uma vez que não é possível estudar ou modificar o programa sem acessar o código-fonte.

Para que as quatro liberdades sejam satisfeitas é necessário que o programa seja distribuído juntamente com o seu código-fonte e que não sejam colocadas restrições para que os usuários alterem e redistribuam esse código.

A liberdade de executar o programa significa que qualquer tipo de pessoa física ou jurídica pode utilizar o software em quantos computadores quiser, em qualquer tipo de sistema computacional, para qualquer tipo de trabalho ou atividade, sem nenhuma restrição imposta pelo fornecedor.

A liberdade de redistribuir o programa executável (em formato binário) necessariamente inclui a obrigatoriedade de disponibilizar seus códigos-fonte. Caso o software venha a ser modificado e o autor da modificação queira distribuí-lo, gratuitamente ou não, será também obrigatória a distribuição do código fonte das modificações, desde que elas venham a integrar o programa. Não é necessária a autorização do autor ou do distribuidor do software para que ele possa ser redistribuído, já que as licenças de software livre assim o permitem.


Para entender e saber mais sobre software livre, acesse a página/verbete na Wikipédia sobre o assunto (que contém o texto usando aqui nesta seção):

https://pt.wikipedia.org/wiki/Software_livre

Sistema operacional e comandos de shell em GNU/Linux[editar | editar código-fonte]

Um Sistema Operacional (SO) é o conjunto de programas que gerenciam recursos do computador e que faz comunicação entre o hardware e os demais programas. O Sistema Operacional provê uma plataforma de interação de usuário com a máquina.

O GNU/Linux e suas distribuições (como Debian, Ubuntu e Redhat) são sistemas operacionais baseados em um mesmo núcleo (kernel Linux) que é a parte mais importante de um sistema operacional: ele executa funções essenciais para gerenciar recursos como processador, memória, realizar a comunicação de linguagem de baixo nível (linguagem de máquina) com o hardware.

O GNU/Linux é um sistema operacional livre, de forma que surgiram distribuições, ou seja, "versões", organizadas e personalizadas para diferentes usuários, podendo ter a interface gráfica padrão e o sistema de gerenciamento de pacotes de software (para instalação e atualizações) diferentes.


O que é um comando?

Um comando é uma instrução especifica dada ao computador para que ele realize uma determinada ação. Por exemplo: Acessar uma pasta do HD; Abrir um arquivo; Mudar a formatação de um arquivo; etc.

Abaixo encontra-se os comandos mais utilizados no Terminal do Linux e suas respectivas funções.

Manipulando arquivos

  • touch

Usado para criar um arquivo vazio, isto é, sem nenhum dado no arquivo e sem formatação. É necessário especificar o nome do arquivo que você deseja criar após o comando.

Exemplo: touch aula1

$ touch <Nome do Arquivo>.

Recomendação ao instrutor(a):Criar um arquivo de texto .txt
  • mkdir

Usado para criar novas pastas, sendo necessário especificar o nome da nova pasta.

Exemplo: mkdir Reprogramar.

mkdir <nova_pasta>

Recomendação ao instrutor(a): Criar uma pasta para guardar todos os arquivos feito em atividades anteriores.
  • cp

Comando utilizado para copiar arquivos e pastas em que não altera-se os arquivos ou pastas do local de origem e destina os arquivos copiados para uma nova pasta.

É necessário estar na mesma pasta do arquivo ou pasta, após o comando especificar o nome, teclar espaço e especificar o destino.

cp <nome do arquivo/pasta> <destino>

  • mv

Comando utilizado para mover arquivos e pastas ou também pode ser usado para renomear arquivos. Ao mover um arquivo a original é excluída e só é mantida a nova cópia.Após o comando é necessário especificar o nome do arquivo, teclar espaço, e especificar o destino. Você pode verificar que o arquivo original foi excluído utilizando o comando ls.

mv <nome do arquivo> <destino>

Recomendação ao instrutor(a): Mover todos os arquivos produzidos nesse curso para a nova pasta que foi criada.

Para mover uma pasta é necessário utilizar o sinalizador “ -r “ , OBS: é importante durante sua navegação no shell, não estar dentro da pasta que será movida.

mv -r <nome da pasta> <destino>

Para renomear um arquivo, após o comando você deve especificar o nome do arquivo que deseja renomear, teclar espaço e especificar o novo nome do arquivo.

mv <nome antigo> <novo nome>

  • rm

Utilizado para excluir arquivos e pastas, sendo a exclusão permanente, então tome cuidado pois após o comando não é possível recuperar os arquivos deletados. Também é necessário especificar o nome do arquivo ou da pasta após o comando.

rm <Nome do Arquivo ou Pasta>


Visualizar Arquivo

  • cat

Comando utilizado para visualizar um arquivo, após o comando será impresso na tela as informações pertencentes ao arquivo. É necessário especificar o nome do arquivo e sua formatação ( Anotação.txt ) após o comando.

Exemplo: cat Anotação.txt

cat <nome_do_arquivo.formato>


Comando Echo no Linux

  • echo

É um simples comando utilizado para imprimir na tela um texto, sendo necessário ditar qual texto ou frase desejada após o comando.

Exemplo: echo “Olá Mundo”

echo <texto>


Comando de texto

  • grep

Comando utilizado para pesquisar um determinado dado dentro de um arquivo de texto. Será impresso na tela as linhas onde foi encontrado o dado pesquisado. Após o comando é necessário especificar o dado que deseja buscar, teclar espaço, e especificar o arquivo de texto.

Exemplo: grep ‘a’ texto.txt

grep <dado> <arquivo de texto.txt>


I/O redimensionamento

Comando utilizados para redirecionar dados, isto é, conseguir enviar dados para arquivos ao mesmo tempo que utiliza outros comandos. Os dados que podemos redirecionar são aqueles que são digitados no teclado (entrada), impressos na tela (saída) e mensagens de erro ( que é produzida automaticamente pelo terminal quando ocorre um erro ).

Podemos utilizar o operador ‘ > ’ para redirecionar um arquivo ou uma saída de dados.

Exemplo: echo “Olá Mundo” > texto.txt . E podemos visualizar os dados redirecionados para dentro do arquivo texto.txt usando o comando cat.

Podemos utilizar os dados de um arquivo como a entrada e redirecionar sua saída para outro arquivo.

Exemplo: Temos o documento lista.txt que contém uma lista de 0 a 9 com números desordenados, e vamos utilizar ele como entrada de dados da seguinte maneira.

sort é um comando que organiza de maneira crescente os dados dentro de um arquivo.

sort < lista.txt > listaOrdenada.txt. Mesmo sem ter o arquivo listaOrdenada.txt na sua pasta o comando irá criar o arquivo e armazenar os dados.


Recomendação ao instrutor(a): Recomendação: Se possível, instalar um programa no Linux, como o Python. Abordar o gerenciador de pacotes, com o comando apt-get, no Debian/Ubuntu, por exemplo.